import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Sent: Monday, |Tuesday, |Wednesday, |Thursday, |Friday, |Saturday, |Sunday, )(\\d\\d\\s|\\d\\s)(January |February |March |April |May |June |July |August |September |October |November |December )(20\\d\\d)";
final String string = "From: john@workplace.com\n"
+ "Sent: Thursday, 23 May 2019 7:14 AM\n"
+ "To: Team Inbox\n"
+ "Subject: Send me some more cookies";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}