#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)honoraires?(\s(d\')?agences?)? inclus?"
Local $sString = "[Honoraires inclus]" & @CRLF & _
"REGEX = honoraires?(\s(d\')?agences?)? inclus?" & @CRLF & _
"honoraires d'agence inclus" & @CRLF & _
"honoraires agence inclus" & @CRLF & _
"honoraires inclus" & @CRLF & _
"" & @CRLF & _
"[Hors Honoraires]" & @CRLF & _
"REGEX = (hors\s)?honoraires?(\sexlus?)?" & @CRLF & _
"hors honoraires" & @CRLF & _
"honoraires exclus" & @CRLF & _
"" & @CRLF & _
"=> https://colab.research.google.com/drive/1pcExD9IQfGtDWp868WhSWJP_Wsdev3QE#scrollTo=bhe-zIRlpOyx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")