package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)honoraires?(\s(d\')?agences?)? inclus?`)
var str = `[Honoraires inclus]
REGEX = honoraires?(\s(d\')?agences?)? inclus?
honoraires d'agence inclus
honoraires agence inclus
honoraires inclus
[Hors Honoraires]
REGEX = (hors\s)?honoraires?(\sexlus?)?
hors honoraires
honoraires exclus
=> https://colab.research.google.com/drive/1pcExD9IQfGtDWp868WhSWJP_Wsdev3QE#scrollTo=bhe-zIRlpOyx`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}