import re
regex = re.compile(r"honoraires?(\s(d\')?agences?)? inclus?", flags=re.MULTILINE)
test_str = ("[Honoraires inclus]\n"
"REGEX = honoraires?(\\s(d\\')?agences?)? inclus?\n"
"honoraires d'agence inclus\n"
"honoraires agence inclus\n"
"honoraires inclus\n\n"
"[Hors Honoraires]\n"
"REGEX = (hors\\s)?honoraires?(\\sexlus?)?\n"
"hors honoraires\n"
"honoraires exclus\n\n"
"=> https://colab.research.google.com/drive/1pcExD9IQfGtDWp868WhSWJP_Wsdev3QE#scrollTo=bhe-zIRlpOyx")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")