import Foundation
let pattern = #"honoraires?(\s(d\')?agences?)? inclus?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
[Honoraires inclus]
REGEX = honoraires?(\s(d\')?agences?)? inclus?
honoraires d'agence inclus
honoraires agence inclus
honoraires inclus
[Hors Honoraires]
REGEX = (hors\s)?honoraires?(\sexlus?)?
hors honoraires
honoraires exclus
=> https://colab.research.google.com/drive/1pcExD9IQfGtDWp868WhSWJP_Wsdev3QE#scrollTo=bhe-zIRlpOyx
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)