$re = '/honoraires?(\s(d\')?agences?)? inclus?/m';
$str = '[Honoraires inclus]
REGEX = honoraires?(\\s(d\\\')?agences?)? inclus?
honoraires d\'agence inclus
honoraires agence inclus
honoraires inclus
[Hors Honoraires]
REGEX = (hors\\s)?honoraires?(\\sexlus?)?
hors honoraires
honoraires exclus
=> https://colab.research.google.com/drive/1pcExD9IQfGtDWp868WhSWJP_Wsdev3QE#scrollTo=bhe-zIRlpOyx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);