using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\W(from|import|require\(|require\.context\(|import\()\s*)['""`]((\.+|src)\/.+?)['""$`]";
string input = @"import sdf from './sdf'
from ""./hello""
from ""./hello'
import ""./sdsd""
const img = require( `src/sdfsdf${name}.png`)
const img = require( `../../${name}.png`)
const img = require.context( `../../${name}.png`)
import ""./sdsd""
import {} from './sdsdsd'
import {} from ""../sdsdsd""
// import(""./sdfsdf"");
import(""./sdfsdfsdf"");
const foo = import('../sdf');
// require
const images = require(`./sdfsdf${namme}`);
require( './sdfsdf' );
// require.context
require.context(""./sdf""
const sdf= await import('./sdfsdf')
const aa = require('./sdfsdf')
const aa = require(`./sdfsdf/${abc}`)
const aa = require('./sdfsdf/')
// export from
export * from './interface'
import(`./sdf${1}`)
import(`./sdfsdf"")
const dfdf = '../sdfsdfsdf'
let fpath = 'src/modules/' + name";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}