$re = '/(?<=\W(from|import|require\(|require\.context\(|import\()\s*)[\'"`]((\.+|src)\/.+?)[\'"$`]/';
$str = 'import sdf from \'./sdf\'
from "./hello"
from "./hello\'
import "./sdsd"
const img = require( `src/sdfsdf${name}.png`)
const img = require( `../../${name}.png`)
const img = require.context( `../../${name}.png`)
import "./sdsd"
import {} from \'./sdsdsd\'
import {} from "../sdsdsd"
// import("./sdfsdf");
import("./sdfsdfsdf");
const foo = import(\'../sdf\');
// require
const images = require(`./sdfsdf${namme}`);
require( \'./sdfsdf\' );
// require.context
require.context("./sdf"
const sdf= await import(\'./sdfsdf\')
const aa = require(\'./sdfsdf\')
const aa = require(`./sdfsdf/${abc}`)
const aa = require(\'./sdfsdf/\')
// export from
export * from \'./interface\'
import(`./sdf${1}`)
import(`./sdfsdf")
const dfdf = \'../sdfsdfsdf\'
let fpath = \'src/modules/\' + name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);