import re
regex = re.compile(r"(?<=\W(from|import|require\(|require\.context\(|import\()\s*)['\"`]((\.+|src)\/.+?)['\"$`]")
test_str = ("import sdf from './sdf'\n"
"from \"./hello\"\n"
"from \"./hello'\n"
"import \"./sdsd\"\n"
"const img = require( `src/sdfsdf${name}.png`)\n"
"const img = require( `../../${name}.png`)\n"
"const img = require.context( `../../${name}.png`)\n\n"
"import \"./sdsd\"\n\n\n"
"import {} from './sdsdsd'\n\n"
"import {} from \"../sdsdsd\"\n\n"
"// import(\"./sdfsdf\");\n\n"
"import(\"./sdfsdfsdf\");\n"
"const foo = import('../sdf');\n\n"
"// require\n"
"const images = require(`./sdfsdf${namme}`);\n"
"require( './sdfsdf' );\n"
"// require.context\n"
"require.context(\"./sdf\"\n\n"
"const sdf= await import('./sdfsdf')\n"
"const aa = require('./sdfsdf')\n"
"const aa = require(`./sdfsdf/${abc}`)\n"
"const aa = require('./sdfsdf/')\n\n"
"// export from \n"
"export * from './interface'\n\n"
"import(`./sdf${1}`)\n"
"import(`./sdfsdf\")\n\n"
"const dfdf = '../sdfsdfsdf'\n"
"let fpath = 'src/modules/' + name")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")