import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\W(from|import|require\\(|require\\.context\\(|import\\()\\s*)['\"`]((\\.+|src)\\/.+?)['\"$`]";
final String string = "import sdf from './sdf'\n"
+ "from \"./hello\"\n"
+ "from \"./hello'\n"
+ "import \"./sdsd\"\n"
+ "const img = require( `src/sdfsdf${name}.png`)\n"
+ "const img = require( `../../${name}.png`)\n"
+ "const img = require.context( `../../${name}.png`)\n\n"
+ "import \"./sdsd\"\n\n\n"
+ "import {} from './sdsdsd'\n\n"
+ "import {} from \"../sdsdsd\"\n\n"
+ "// import(\"./sdfsdf\");\n\n"
+ "import(\"./sdfsdfsdf\");\n"
+ "const foo = import('../sdf');\n\n"
+ "// require\n"
+ "const images = require(`./sdfsdf${namme}`);\n"
+ "require( './sdfsdf' );\n"
+ "// require.context\n"
+ "require.context(\"./sdf\"\n\n"
+ "const sdf= await import('./sdfsdf')\n"
+ "const aa = require('./sdfsdf')\n"
+ "const aa = require(`./sdfsdf/${abc}`)\n"
+ "const aa = require('./sdfsdf/')\n\n"
+ "// export from \n"
+ "export * from './interface'\n\n"
+ "import(`./sdf${1}`)\n"
+ "import(`./sdfsdf\")\n\n"
+ "const dfdf = '../sdfsdfsdf'\n"
+ "let fpath = 'src/modules/' + name";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}