# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<[^<>]*>//gm;t' <<< "This is a te<8239154>st str<ass31>ing"