const regex = /<[^<>]*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[^<>]*>', 'gm')
const str = `This is a te<8239154>st str<ass31>ing`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);