import re
regex = re.compile(r"<[^<>]*>", flags=re.MULTILINE)
test_str = "This is a te<8239154>st str<ass31>ing"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)