re = /<[^<>]*>/m
str = 'This is a te<8239154>st str<ass31>ing'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result