$re = '/<[^<>]*>/m';
$str = 'This is a te<8239154>st str<ass31>ing';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;