#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*?linkedin.com\/[a-z A-z 0-9]+\/([a-z A-z 0-9 -]*)\/*"
Local $sString = "https://www.linkedin.com/in/gregory-kovalchuk-5869946a/" & @CRLF & _
"linkedin.com/in/devin-slattery-94342992"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")