package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?linkedin.com\/[a-z A-z 0-9]+\/([a-z A-z 0-9 -]*)\/*`)
var str = `https://www.linkedin.com/in/gregory-kovalchuk-5869946a/
linkedin.com/in/devin-slattery-94342992`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}