re = /.*?linkedin.com\/[a-z A-z 0-9]+\/([a-z A-z 0-9 -]*)\/*/m
str = 'https://www.linkedin.com/in/gregory-kovalchuk-5869946a/
linkedin.com/in/devin-slattery-94342992'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end