import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?linkedin.com\\/[a-z A-z 0-9]+\\/([a-z A-z 0-9 -]*)\\/*";
final String string = "https://www.linkedin.com/in/gregory-kovalchuk-5869946a/\n"
+ "linkedin.com/in/devin-slattery-94342992";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}