$re = '/.*?linkedin.com\/[a-z A-z 0-9]+\/([a-z A-z 0-9 -]*)\/*/m';
$str = 'https://www.linkedin.com/in/gregory-kovalchuk-5869946a/
linkedin.com/in/devin-slattery-94342992';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);