#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?m)^-(?=\h)"
Local $sString = "- JavaScript" & @CRLF & _
"- Unicode - Wikipedia" & @CRLF & _
"- CSS-tricks"
Local $sSubst = " -"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)