re = /(?m)^-(?=\h)/m
str = '- JavaScript
- Unicode - Wikipedia
- CSS-tricks'
subst = ' -'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result