using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^-(?=\h)";
string substitution = @" -";
string input = @"- JavaScript
- Unicode - Wikipedia
- CSS-tricks";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}