$re = '/(?m)^-(?=\h)/m';
$str = '- JavaScript
- Unicode - Wikipedia
- CSS-tricks';
$subst = " -";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;