import Foundation
let pattern = #"(?m)^-(?=\h)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
- JavaScript
- Unicode - Wikipedia
- CSS-tricks
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" -"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)