use strict;
my $str = '- JavaScript
- Unicode - Wikipedia
- CSS-tricks';
my $regex = qr/(?m)^-(?=\h)/mp;
my $subst = ' -';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";