#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)[\n.]*(<tr class="hl" >[.\n]*<\/tr>)[.\n]*"
Local $sString = "<table id="hhh"" & @CRLF & _
" class="row_table_data">" & @CRLF & _
" <thead>" & @CRLF & _
" <tr>" & @CRLF & _
" <td></td>" & @CRLF & _
" <td>J</td>" & @CRLF & _
" <td>N</td>" & @CRLF & _
" <td>E</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </thead>" & @CRLF & _
" <tbody>" & @CRLF & _
"" & @CRLF & _
" <tr class="hover">" & @CRLF & _
"" & @CRLF & _
" <td class="ras " >2</td>" & @CRLF & _
" <td class="plsa " ><a href="">X</a> </td>" & @CRLF & _
" <td class="lefv " >3</td>" & @CRLF & _
" <td class="xpm lc" >1</td>" & @CRLF & _
" </tr>" & @CRLF & _
"" & @CRLF & _
" <tr class="hl" >" & @CRLF & _
"" & @CRLF & _
" <td class="ras fc" >3</td>" & @CRLF & _
" <td class="plsa " ><a href="">M</a> </td>" & @CRLF & _
" <td class="lefv " >3</td>" & @CRLF & _
" <td class="xpm lc" >3</td>" & @CRLF & _
" </tr>" & @CRLF & _
"" & @CRLF & _
" <tr class="hover">" & @CRLF & _
"" & @CRLF & _
" <td class="ras " >4</td>" & @CRLF & _
" <td class="plsa " ><a href="">l</a> </td>" & @CRLF & _
" <td class="lefv " >3</td>" & @CRLF & _
" <td class="xpm " >3</td>" & @CRLF & _
" </tr>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")