import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\n.]*(<tr class=\"hl\" >[.\\n]*<\\/tr>)[.\\n]*";
final String string = "<table id=\"hhh\"\n"
+ " class=\"row_table_data\">\n"
+ " <thead>\n"
+ " <tr>\n"
+ " <td></td>\n"
+ " <td>J</td>\n"
+ " <td>N</td>\n"
+ " <td>E</td>\n"
+ " </tr>\n"
+ " </thead>\n"
+ " <tbody>\n\n"
+ " <tr class=\"hover\">\n\n"
+ " <td class=\"ras \" >2</td>\n"
+ " <td class=\"plsa \" ><a href=\"\">X</a> </td>\n"
+ " <td class=\"lefv \" >3</td>\n"
+ " <td class=\"xpm lc\" >1</td>\n"
+ " </tr>\n\n"
+ " <tr class=\"hl\" >\n\n"
+ " <td class=\"ras fc\" >3</td>\n"
+ " <td class=\"plsa \" ><a href=\"\">M</a> </td>\n"
+ " <td class=\"lefv \" >3</td>\n"
+ " <td class=\"xpm lc\" >3</td>\n"
+ " </tr>\n\n"
+ " <tr class=\"hover\">\n\n"
+ " <td class=\"ras \" >4</td>\n"
+ " <td class=\"plsa \" ><a href=\"\">l</a> </td>\n"
+ " <td class=\"lefv \" >3</td>\n"
+ " <td class=\"xpm \" >3</td>\n"
+ " </tr>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}