// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)[\n.]*(<tr class="hl" >[.\n]*<\/tr>)[.\n]*"#).unwrap();
let string = "<table id=\"hhh\"
class=\"row_table_data\">
<thead>
<tr>
<td></td>
<td>J</td>
<td>N</td>
<td>E</td>
</tr>
</thead>
<tbody>
<tr class=\"hover\">
<td class=\"ras \" >2</td>
<td class=\"plsa \" ><a href=\"\">X</a> </td>
<td class=\"lefv \" >3</td>
<td class=\"xpm lc\" >1</td>
</tr>
<tr class=\"hl\" >
<td class=\"ras fc\" >3</td>
<td class=\"plsa \" ><a href=\"\">M</a> </td>
<td class=\"lefv \" >3</td>
<td class=\"xpm lc\" >3</td>
</tr>
<tr class=\"hover\">
<td class=\"ras \" >4</td>
<td class=\"plsa \" ><a href=\"\">l</a> </td>
<td class=\"lefv \" >3</td>
<td class=\"xpm \" >3</td>
</tr>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}