$re = '/[\n.]*(<tr class="hl" >[.\n]*<\/tr>)[.\n]*/i';
$str = '<table id="hhh"
class="row_table_data">
<thead>
<tr>
<td></td>
<td>J</td>
<td>N</td>
<td>E</td>
</tr>
</thead>
<tbody>
<tr class="hover">
<td class="ras " >2</td>
<td class="plsa " ><a href="">X</a> </td>
<td class="lefv " >3</td>
<td class="xpm lc" >1</td>
</tr>
<tr class="hl" >
<td class="ras fc" >3</td>
<td class="plsa " ><a href="">M</a> </td>
<td class="lefv " >3</td>
<td class="xpm lc" >3</td>
</tr>
<tr class="hover">
<td class="ras " >4</td>
<td class="plsa " ><a href="">l</a> </td>
<td class="lefv " >3</td>
<td class="xpm " >3</td>
</tr>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);