package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[\n.]*(<tr class="hl" >[.\n]*<\/tr>)[.\n]*`)
var str = `<table id="hhh"
class="row_table_data">
<thead>
<tr>
<td></td>
<td>J</td>
<td>N</td>
<td>E</td>
</tr>
</thead>
<tbody>
<tr class="hover">
<td class="ras " >2</td>
<td class="plsa " ><a href="">X</a> </td>
<td class="lefv " >3</td>
<td class="xpm lc" >1</td>
</tr>
<tr class="hl" >
<td class="ras fc" >3</td>
<td class="plsa " ><a href="">M</a> </td>
<td class="lefv " >3</td>
<td class="xpm lc" >3</td>
</tr>
<tr class="hover">
<td class="ras " >4</td>
<td class="plsa " ><a href="">l</a> </td>
<td class="lefv " >3</td>
<td class="xpm " >3</td>
</tr>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}