import re
regex = re.compile(r"[\n.]*(<tr class=\"hl\" >[.\n]*<\/tr>)[.\n]*", flags=re.IGNORECASE)
test_str = ("<table id=\"hhh\"\n"
" class=\"row_table_data\">\n"
" <thead>\n"
" <tr>\n"
" <td></td>\n"
" <td>J</td>\n"
" <td>N</td>\n"
" <td>E</td>\n"
" </tr>\n"
" </thead>\n"
" <tbody>\n\n"
" <tr class=\"hover\">\n\n"
" <td class=\"ras \" >2</td>\n"
" <td class=\"plsa \" ><a href=\"\">X</a> </td>\n"
" <td class=\"lefv \" >3</td>\n"
" <td class=\"xpm lc\" >1</td>\n"
" </tr>\n\n"
" <tr class=\"hl\" >\n\n"
" <td class=\"ras fc\" >3</td>\n"
" <td class=\"plsa \" ><a href=\"\">M</a> </td>\n"
" <td class=\"lefv \" >3</td>\n"
" <td class=\"xpm lc\" >3</td>\n"
" </tr>\n\n"
" <tr class=\"hover\">\n\n"
" <td class=\"ras \" >4</td>\n"
" <td class=\"plsa \" ><a href=\"\">l</a> </td>\n"
" <td class=\"lefv \" >3</td>\n"
" <td class=\"xpm \" >3</td>\n"
" </tr>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")