#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)\.?([^.]*Bylaw.+?(\.|$))"
Local $sString = "hello the world . a Bylaw to provide for the government and management of the Water Works System in the City and th" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"e collection of Rents, Rates, and charges for water. blah blah blah." & @CRLF & _
"" & @CRLF & _
"A bylaw to do something"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")