using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.?([^.]*Bylaw.+?(\.|$))";
string input = @"hello the world . a Bylaw to provide for the government and management of the Water Works System in the City and th
e collection of Rents, Rates, and charges for water. blah blah blah.
A bylaw to do something";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}