// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?is)\.?([^.]*Bylaw.+?(\.|$))").unwrap();
let string = "hello the world . a Bylaw to provide for the government and management of the Water Works System in the City and th
e collection of Rents, Rates, and charges for water. blah blah blah.
A bylaw to do something";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}