import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.?([^.]*Bylaw.+?(\\.|$))";
final String string = "hello the world . a Bylaw to provide for the government and management of the Water Works System in the City and th\n\n\n\n"
+ "e collection of Rents, Rates, and charges for water. blah blah blah.\n\n"
+ "A bylaw to do something";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}