package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)\.?([^.]*Bylaw.+?(\.|$))`)
var str = `hello the world . a Bylaw to provide for the government and management of the Water Works System in the City and th
e collection of Rents, Rates, and charges for water. blah blah blah.
A bylaw to do something`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}