using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!.*\..*\.)(?!.*_.*_)[A-Za-z0-9_.])*$";
string input = @"abcd.efg
abcd.efg.
abcd_efg
abcd_efg_
123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}