$re = '/^((?!.*\..*\.)(?!.*_.*_)[A-Za-z0-9_.])*$/m';
$str = 'abcd.efg
abcd.efg.
abcd_efg
abcd_efg_
123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);