import re
regex = re.compile(r"^((?!.*\..*\.)(?!.*_.*_)[A-Za-z0-9_.])*$", flags=re.MULTILINE)
test_str = ("abcd.efg\n"
"abcd.efg.\n"
"abcd_efg\n"
"abcd_efg_\n"
"123")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")