#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w+)\s*=\s*(?:(?:"([^"]*)"|'([^']*)'|([^;\n"']+))\s*(?:;|$))"
Local $sString = "param1=abc" & @CRLF & _
"" & @CRLF & _
"param2 = abc" & @CRLF & _
"" & @CRLF & _
"param3 = "ab'c"" & @CRLF & _
"" & @CRLF & _
"param4='a"b"c'" & @CRLF & _
"" & @CRLF & _
"param5="abc=def"" & @CRLF & _
"" & @CRLF & _
"param7="hello'" & @CRLF & _
"" & @CRLF & _
"(\w+) - Elkapja a paraméter nevét." & @CRLF & _
"\s*=\s* - Keresi az egyenlőségjelet a felesleges szóközökkel együtt." & @CRLF & _
"(?:"([^"]*)"|'([^']*)'|([^;\n"']+)) - Elkapja az értéket a következő feltételekkel:" & @CRLF & _
""[^"]*": Dupla idézőjelek közötti szöveget, ami nem tartalmaz további dupla idézőjeleket." & @CRLF & _
"'[^']*': Egyszerű idézőjelek közötti szöveget, ami nem tartalmaz további egyszerű idézőjeleket." & @CRLF & _
"[^;\n"']+: Szöveget, ami nem tartalmaz sem pontosvesszőt, sem sorvégét, sem idézőjelet." & @CRLF & _
"\s*(?:;|$) - Keres egy opcionális sorvégi vagy pontosvessző elválasztót."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")