use strict;
my $str = 'param1=abc
param2 = abc
param3 = "ab\'c"
param4=\'a"b"c\'
param5="abc=def"
param7="hello\'
(\\w+) - Elkapja a paraméter nevét.
\\s*=\\s* - Keresi az egyenlőségjelet a felesleges szóközökkel együtt.
(?:"([^"]*)"|\'([^\']*)\'|([^;\\n"\']+)) - Elkapja az értéket a következő feltételekkel:
"[^"]*": Dupla idézőjelek közötti szöveget, ami nem tartalmaz további dupla idézőjeleket.
\'[^\']*\': Egyszerű idézőjelek közötti szöveget, ami nem tartalmaz további egyszerű idézőjeleket.
[^;\\n"\']+: Szöveget, ami nem tartalmaz sem pontosvesszőt, sem sorvégét, sem idézőjelet.
\\s*(?:;|$) - Keres egy opcionális sorvégi vagy pontosvessző elválasztót.';
my $regex = qr/(\w+)\s*=\s*(?:(?:"([^"]*)"|'([^']*)'|([^;\n"']+))\s*(?:;|$))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}