using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\s*=\s*(?:(?:""([^""]*)""|'([^']*)'|([^;\n""']+))\s*(?:;|$))";
string input = @"param1=abc
param2 = abc
param3 = ""ab'c""
param4='a""b""c'
param5=""abc=def""
param7=""hello'
(\w+) - Elkapja a paraméter nevét.
\s*=\s* - Keresi az egyenlőségjelet a felesleges szóközökkel együtt.
(?:""([^""]*)""|'([^']*)'|([^;\n""']+)) - Elkapja az értéket a következő feltételekkel:
""[^""]*"": Dupla idézőjelek közötti szöveget, ami nem tartalmaz további dupla idézőjeleket.
'[^']*': Egyszerű idézőjelek közötti szöveget, ami nem tartalmaz további egyszerű idézőjeleket.
[^;\n""']+: Szöveget, ami nem tartalmaz sem pontosvesszőt, sem sorvégét, sem idézőjelet.
\s*(?:;|$) - Keres egy opcionális sorvégi vagy pontosvessző elválasztót.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}