import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)\\s*=\\s*(?:(?:\"([^\"]*)\"|'([^']*)'|([^;\\n\"']+))\\s*(?:;|$))";
final String string = "param1=abc\n\n"
+ "param2 = abc\n\n"
+ "param3 = \"ab'c\"\n\n"
+ "param4='a\"b\"c'\n\n"
+ "param5=\"abc=def\"\n\n"
+ "param7=\"hello'\n\n"
+ "(\\w+) - Elkapja a paraméter nevét.\n"
+ "\\s*=\\s* - Keresi az egyenlőségjelet a felesleges szóközökkel együtt.\n"
+ "(?:\"([^\"]*)\"|'([^']*)'|([^;\\n\"']+)) - Elkapja az értéket a következő feltételekkel:\n"
+ "\"[^\"]*\": Dupla idézőjelek közötti szöveget, ami nem tartalmaz további dupla idézőjeleket.\n"
+ "'[^']*': Egyszerű idézőjelek közötti szöveget, ami nem tartalmaz további egyszerű idézőjeleket.\n"
+ "[^;\\n\"']+: Szöveget, ami nem tartalmaz sem pontosvesszőt, sem sorvégét, sem idézőjelet.\n"
+ "\\s*(?:;|$) - Keres egy opcionális sorvégi vagy pontosvessző elválasztót.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}