$re = '/(\w+)\s*=\s*(?:(?:"([^"]*)"|\'([^\']*)\'|([^;\n"\']+))\s*(?:;|$))/m';
$str = 'param1=abc
param2 = abc
param3 = "ab\'c"
param4=\'a"b"c\'
param5="abc=def"
param7="hello\'
(\\w+) - Elkapja a paraméter nevét.
\\s*=\\s* - Keresi az egyenlőségjelet a felesleges szóközökkel együtt.
(?:"([^"]*)"|\'([^\']*)\'|([^;\\n"\']+)) - Elkapja az értéket a következő feltételekkel:
"[^"]*": Dupla idézőjelek közötti szöveget, ami nem tartalmaz további dupla idézőjeleket.
\'[^\']*\': Egyszerű idézőjelek közötti szöveget, ami nem tartalmaz további egyszerű idézőjeleket.
[^;\\n"\']+: Szöveget, ami nem tartalmaz sem pontosvesszőt, sem sorvégét, sem idézőjelet.
\\s*(?:;|$) - Keres egy opcionális sorvégi vagy pontosvessző elválasztót.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);