# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w+)\s*=\s*(?:(?:\"([^\"]*)\"|'([^']*)'|([^;\n\"']+))\s*(?:;|$))"
test_str = ("param1=abc\n\n"
"param2 = abc\n\n"
"param3 = \"ab'c\"\n\n"
"param4='a\"b\"c'\n\n"
"param5=\"abc=def\"\n\n"
"param7=\"hello'\n\n"
"(\\w+) - Elkapja a paraméter nevét.\n"
"\\s*=\\s* - Keresi az egyenlőségjelet a felesleges szóközökkel együtt.\n"
"(?:\"([^\"]*)\"|'([^']*)'|([^;\\n\"']+)) - Elkapja az értéket a következő feltételekkel:\n"
"\"[^\"]*\": Dupla idézőjelek közötti szöveget, ami nem tartalmaz további dupla idézőjeleket.\n"
"'[^']*': Egyszerű idézőjelek közötti szöveget, ami nem tartalmaz további egyszerű idézőjeleket.\n"
"[^;\\n\"']+: Szöveget, ami nem tartalmaz sem pontosvesszőt, sem sorvégét, sem idézőjelet.\n"
"\\s*(?:;|$) - Keres egy opcionális sorvégi vagy pontosvessző elválasztót.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.