#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(GRUB_CMDLINE_LINUX_DEFAULT=(?!.*elevator=noop).*)\""
Local $sString = "GRUB_CMDLINE_LINUX_DEFAULT="quiet"" & @CRLF & _
"GRUB_CMDLINE_LINUX_DEFAULT="console=tty1 console=ttyS0"" & @CRLF & _
"" & @CRLF & _
"GRUB_CMDLINE_LINUX_DEFAULT="quiet elevator=noop"" & @CRLF & _
"GRUB_CMDLINE_LINUX_DEFAULT="console=tty1 console=ttyS0 elevator=noop"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")