const regex = new RegExp('^(GRUB_CMDLINE_LINUX_DEFAULT=(?!.*elevator=noop).*)\\"', 'gm')
const str = `GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX_DEFAULT="console=tty1 console=ttyS0"
GRUB_CMDLINE_LINUX_DEFAULT="quiet elevator=noop"
GRUB_CMDLINE_LINUX_DEFAULT="console=tty1 console=ttyS0 elevator=noop"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}