import re
regex = re.compile(r"^(GRUB_CMDLINE_LINUX_DEFAULT=(?!.*elevator=noop).*)\"", flags=re.MULTILINE)
test_str = ("GRUB_CMDLINE_LINUX_DEFAULT=\"quiet\"\n"
"GRUB_CMDLINE_LINUX_DEFAULT=\"console=tty1 console=ttyS0\"\n\n"
"GRUB_CMDLINE_LINUX_DEFAULT=\"quiet elevator=noop\"\n"
"GRUB_CMDLINE_LINUX_DEFAULT=\"console=tty1 console=ttyS0 elevator=noop\"\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")