import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(GRUB_CMDLINE_LINUX_DEFAULT=(?!.*elevator=noop).*)\\\"";
final String string = "GRUB_CMDLINE_LINUX_DEFAULT=\"quiet\"\n"
+ "GRUB_CMDLINE_LINUX_DEFAULT=\"console=tty1 console=ttyS0\"\n\n"
+ "GRUB_CMDLINE_LINUX_DEFAULT=\"quiet elevator=noop\"\n"
+ "GRUB_CMDLINE_LINUX_DEFAULT=\"console=tty1 console=ttyS0 elevator=noop\"\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}